# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^-]*)\s-\s([^'(]*)\s\(([^\)]*)\)(.*)/$1 $3 - $2$4/gm;t' <<< "Lloyd - Get It Shawty (Ft Young Joc).mp3
Lloyd - Get It Shawty.mp3"