import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^-]*)\\s-\\s([^'(]*)\\s\\(([^\\)]*)\\)(.*)";
final String string = "Lloyd - Get It Shawty (Ft Young Joc).mp3\n"
+ "Lloyd - Get It Shawty.mp3";
final String subst = "$1 $3 - $2$4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}