import Foundation
let pattern = #"([^-]*)\s-\s([^'(]*)\s\(([^\)]*)\)(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Lloyd - Get It Shawty (Ft Young Joc).mp3
Lloyd - Get It Shawty.mp3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 $3 - $2$4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)