$re = '/([^-]*)\s-\s([^\'(]*)\s\(([^\)]*)\)(.*)/m';
$str = 'Lloyd - Get It Shawty (Ft Young Joc).mp3
Lloyd - Get It Shawty.mp3';
$subst = "$1 $3 - $2$4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;