// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([^-]*)\s-\s([^'(]*)\s\(([^\)]*)\)(.*)").unwrap();
let string = "Lloyd - Get It Shawty (Ft Young Joc).mp3
Lloyd - Get It Shawty.mp3";
let substitution = "$1 $3 - $2$4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}