#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([^-]*)\s-\s([^'(]*)\s\(([^\)]*)\)(.*)"
Local $sString = "Lloyd - Get It Shawty (Ft Young Joc).mp3" & @CRLF & _
"Lloyd - Get It Shawty.mp3"
Local $sSubst = "$1 $3 - $2$4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)