using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^-]*)\s-\s([^'(]*)\s\(([^\)]*)\)(.*)";
string substitution = @"$1 $3 - $2$4";
string input = @"Lloyd - Get It Shawty (Ft Young Joc).mp3
Lloyd - Get It Shawty.mp3";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}