#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z]+\d{0,80}$"
Local $sString = "a" & @CRLF & _
"a1" & @CRLF & _
"ab12" & @CRLF & _
"aAc" & @CRLF & _
"aAd12" & @CRLF & _
"aAd12345678901234567890123456789012345678901234567890123456789012345678901234567890" & @CRLF & _
"aAd123456789012345678901234567890123456789012345678901234567890123456789012345678901" & @CRLF & _
"1" & @CRLF & _
"1a"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")