re = /^[a-zA-Z]+\d{0,80}$/m
str = 'a
a1
ab12
aAc
aAd12
aAd12345678901234567890123456789012345678901234567890123456789012345678901234567890
aAd123456789012345678901234567890123456789012345678901234567890123456789012345678901
1
1a'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end