import re
regex = re.compile(r"^[a-zA-Z]+\d{0,80}$", flags=re.MULTILINE)
test_str = ("a\n"
"a1\n"
"ab12\n"
"aAc\n"
"aAd12\n"
"aAd12345678901234567890123456789012345678901234567890123456789012345678901234567890\n"
"aAd123456789012345678901234567890123456789012345678901234567890123456789012345678901\n"
"1\n"
"1a")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")