// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-zA-Z]+\d{0,80}$").unwrap();
let string = "a
a1
ab12
aAc
aAd12
aAd12345678901234567890123456789012345678901234567890123456789012345678901234567890
aAd123456789012345678901234567890123456789012345678901234567890123456789012345678901
1
1a";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}