use strict;
my $str = 'a
a1
ab12
aAc
aAd12
aAd12345678901234567890123456789012345678901234567890123456789012345678901234567890
aAd123456789012345678901234567890123456789012345678901234567890123456789012345678901
1
1a';
my $regex = qr/^[a-zA-Z]+\d{0,80}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}