#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\.?\d*)\W?(?:MC|P)"
Local $sString = "FM.3 MC1" & @CRLF & _
"FM.3 MC1" & @CRLF & _
"FM.3 MC1 P2" & @CRLF & _
"FM.3 P1" & @CRLF & _
"FM.3" & @CRLF & _
"FM.3 P1" & @CRLF & _
"FM.3 MC P1" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")