import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\.?\\d*)\\W?(?:MC|P)";
final String string = "FM.3 MC1\n"
+ "FM.3 MC1\n"
+ "FM.3 MC1 P2\n"
+ "FM.3 P1\n"
+ "FM.3\n"
+ "FM.3 P1\n"
+ "FM.3 MC P1\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}