// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\.?\d*)\W?(?:MC|P)").unwrap();
let string = "FM.3 MC1
FM.3 MC1
FM.3 MC1 P2
FM.3 P1
FM.3
FM.3 P1
FM.3 MC P1
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}