import Foundation
let pattern = #"(\.?\d*)\W?(?:MC|P)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
FM.3 MC1
FM.3 MC1
FM.3 MC1 P2
FM.3 P1
FM.3
FM.3 P1
FM.3 MC P1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)