const regex = /(\.?\d*)\W?(?:MC|P)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\.?\\d*)\\W?(?:MC|P)', 'g')
const str = `FM.3 MC1
FM.3 MC1
FM.3 MC1 P2
FM.3 P1
FM.3
FM.3 P1
FM.3 MC P1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}