package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\.?\d*)\W?(?:MC|P)`)
var str = `FM.3 MC1
FM.3 MC1
FM.3 MC1 P2
FM.3 P1
FM.3
FM.3 P1
FM.3 MC P1
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}