$re = '/(\.?\d*)\W?(?:MC|P)/';
$str = 'FM.3 MC1
FM.3 MC1
FM.3 MC1 P2
FM.3 P1
FM.3
FM.3 P1
FM.3 MC P1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);