#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "@[^@]+@(?!.*@)"
Local $sString = "<pattern>@this is a statement@ @this is also a statement@</pattern>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)