$re = '/@[^@]+@(?!.*@)/';
$str = '<pattern>@this is a statement@ @this is also a statement@</pattern>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;