import re
regex = re.compile(r"@[^@]+@(?!.*@)")
test_str = "<pattern>@this is a statement@ @this is also a statement@</pattern>"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)