using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@[^@]+@(?!.*@)";
string substitution = @"";
string input = @"<pattern>@this is a statement@ @this is also a statement@</pattern>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}