# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=href=')()(?={{.*}})/https:\/\/myurl.com?redirect=\1/g;t' <<< "<a href='{{url}}'>Link</a>
<p>This text {{urlAltTag}} will not get replaced</p>
<a href='{{urlAltTag}}' download='true'>Another Link</a>"