import Foundation
let pattern = #"(?<=href=')()(?={{.*}})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<a href='{{url}}'>Link</a>
<p>This text {{urlAltTag}} will not get replaced</p>
<a href='{{urlAltTag}}' download='true'>Another Link</a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"https://myurl.com?redirect=\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)