import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=href=')()(?=\\{\\{.*\\}\\})";
final String string = "<a href='{{url}}'>Link</a>\n\n"
+ "<p>This text {{urlAltTag}} will not get replaced</p>\n\n"
+ "<a href='{{urlAltTag}}' download='true'>Another Link</a>";
final String subst = "https://myurl.com?redirect=\\1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}