$re = '/(?<=href=\')()(?={{.*}})/';
$str = '<a href=\'{{url}}\'>Link</a>
<p>This text {{urlAltTag}} will not get replaced</p>
<a href=\'{{urlAltTag}}\' download=\'true\'>Another Link</a>';
$subst = "https://myurl.com?redirect=\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;