using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=href=')()(?={{.*}})";
string substitution = @"https://myurl.com?redirect=\1";
string input = @"<a href='{{url}}'>Link</a>
<p>This text {{urlAltTag}} will not get replaced</p>
<a href='{{urlAltTag}}' download='true'>Another Link</a>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}