#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<=href=')()(?={{.*}})"
Local $sString = "<a href='{{url}}'>Link</a>" & @CRLF & _
"" & @CRLF & _
"<p>This text {{urlAltTag}} will not get replaced</p>" & @CRLF & _
"" & @CRLF & _
"<a href='{{urlAltTag}}' download='true'>Another Link</a>"
Local $sSubst = "https://myurl.com?redirect=\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)