use strict;
my $str = '<a href=\'{{url}}\'>Link</a>
<p>This text {{urlAltTag}} will not get replaced</p>
<a href=\'{{urlAltTag}}\' download=\'true\'>Another Link</a>';
my $regex = qr/(?<=href=')()(?={{.*}})/p;
my $subst = 'https://myurl.com?redirect=\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";