#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*[^\d](19|20)\d{2}(0[1-9]|1[0-2])(0[1-9]|[12]\d|3[01])$"
Local $sString = "fileNamePrefix_20171219" & @CRLF & _
"fileNamePrefix_20170019" & @CRLF & _
"fileNamePrefix_20171200" & @CRLF & _
"fileNamePrefix_19631219" & @CRLF & _
"fileNamePrefix_18631219" & @CRLF & _
"fileNamePrefix_20171319" & @CRLF & _
"fileNamePrefix_20171240" & @CRLF & _
"fileNamePrefix_20171219131415111"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")