package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*[^\d](19|20)\d{2}(0[1-9]|1[0-2])(0[1-9]|[12]\d|3[01])$`)
var str = `fileNamePrefix_20171219
fileNamePrefix_20170019
fileNamePrefix_20171200
fileNamePrefix_19631219
fileNamePrefix_18631219
fileNamePrefix_20171319
fileNamePrefix_20171240
fileNamePrefix_20171219131415111`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}