import re
regex = re.compile(r".*[^\d](19|20)\d{2}(0[1-9]|1[0-2])(0[1-9]|[12]\d|3[01])$", flags=re.MULTILINE)
test_str = ("fileNamePrefix_20171219\n"
"fileNamePrefix_20170019\n"
"fileNamePrefix_20171200\n"
"fileNamePrefix_19631219\n"
"fileNamePrefix_18631219\n"
"fileNamePrefix_20171319\n"
"fileNamePrefix_20171240\n"
"fileNamePrefix_20171219131415111")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")