use strict;
my $str = 'fileNamePrefix_20171219
fileNamePrefix_20170019
fileNamePrefix_20171200
fileNamePrefix_19631219
fileNamePrefix_18631219
fileNamePrefix_20171319
fileNamePrefix_20171240
fileNamePrefix_20171219131415111';
my $regex = qr/.*[^\d](19|20)\d{2}(0[1-9]|1[0-2])(0[1-9]|[12]\d|3[01])$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}