# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?<=[^\W[A-Z])[A-Z]|(?<=\S)[A-Z](?=[a-z]))/ \1/gm;t' <<< "General Manager or VP Torrance, CARequired education
WordWordWord
DaveIsAFKRightNow!Cool
"