const regex = new RegExp('((?<=[^\\W[A-Z])[A-Z]|(?<=\\S)[A-Z](?=[a-z]))', 'gm')
const str = `General Manager or VP Torrance, CARequired education
WordWordWord
DaveIsAFKRightNow!Cool
`;
const subst = ` \1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);