re = /((?<=[^\W[A-Z])[A-Z]|(?<=\S)[A-Z](?=[a-z]))/m
str = 'General Manager or VP Torrance, CARequired education
WordWordWord
DaveIsAFKRightNow!Cool
'
subst = ' \\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result