$re = '/((?<=[^\W[A-Z])[A-Z]|(?<=\S)[A-Z](?=[a-z]))/m';
$str = 'General Manager or VP Torrance, CARequired education
WordWordWord
DaveIsAFKRightNow!Cool
';
$subst = " \1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;