using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<=[^\W[A-Z])[A-Z]|(?<=\S)[A-Z](?=[a-z]))";
string substitution = @" \1";
string input = @"General Manager or VP Torrance, CARequired education
WordWordWord
DaveIsAFKRightNow!Cool
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}