import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?<=[^\\W[A-Z])[A-Z]|(?<=\\S)[A-Z](?=[a-z]))";
final String string = "General Manager or VP Torrance, CARequired education\n"
+ "WordWordWord\n"
+ "DaveIsAFKRightNow!Cool\n";
final String subst = " \\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}