#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^IND\b.*?\h(\d*\.?\d+(?:[UuMmNn])?H|h)\b"
Local $sString = "IND SMD 0402 1.2nH 50pH 390mA 100MOHM" & @CRLF & _
"IND SMD 0402 .2nH 50pH 390mA 100MOHM"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")