using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^IND\b.*?\h(\d*\.?\d+(?:[UuMmNn])?H|h)\b";
string input = @"IND SMD 0402 1.2nH 50pH 390mA 100MOHM
IND SMD 0402 .2nH 50pH 390mA 100MOHM";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}