import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^IND\\b.*?\\h(\\d*\\.?\\d+(?:[UuMmNn])?H|h)\\b";
final String string = "IND SMD 0402 1.2nH 50pH 390mA 100MOHM\n"
+ "IND SMD 0402 .2nH 50pH 390mA 100MOHM";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}