package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^IND\b.*?\h(\d*\.?\d+(?:[UuMmNn])?H|h)\b`)
var str = `IND SMD 0402 1.2nH 50pH 390mA 100MOHM
IND SMD 0402 .2nH 50pH 390mA 100MOHM`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}