const regex = new RegExp('^IND\\b.*?\\h(\\d*\\.?\\d+(?:[UuMmNn])?H|h)\\b', 'mg')
const str = `IND SMD 0402 1.2nH 50pH 390mA 100MOHM
IND SMD 0402 .2nH 50pH 390mA 100MOHM`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}