// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^IND\b.*?\h(\d*\.?\d+(?:[UuMmNn])?H|h)\b").unwrap();
let string = "IND SMD 0402 1.2nH 50pH 390mA 100MOHM
IND SMD 0402 .2nH 50pH 390mA 100MOHM";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}