re = /^IND\b.*?\h(\d*\.?\d+(?:[UuMmNn])?H|h)\b/m
str = 'IND SMD 0402 1.2nH 50pH 390mA 100MOHM
IND SMD 0402 .2nH 50pH 390mA 100MOHM'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end