#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([+-]?) *([ij]?) *(\d+)[.,]?(\d*)([ij])?"
Local $sString = "-15 + 8.14i" & @CRLF & _
"-15+8.14j" & @CRLF & _
"-15 j 8,14" & @CRLF & _
"bad line here" & @CRLF & _
"+23.4-j24" & @CRLF & _
"-35+42.3j" & @CRLF & _
"+24i" & @CRLF & _
"+2.342j" & @CRLF & _
"24.523-i 432,52"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")