using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([+-]?) *([ij]?) *(\d+)[.,]?(\d*)([ij])?";
string input = @"-15 + 8.14i
-15+8.14j
-15 j 8,14
bad line here
+23.4-j24
-35+42.3j
+24i
+2.342j
24.523-i 432,52";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}