import re
regex = re.compile(r"([+-]?) *([ij]?) *(\d+)[.,]?(\d*)([ij])?")
test_str = ("-15 + 8.14i\n"
"-15+8.14j\n"
"-15 j 8,14\n"
"bad line here\n"
"+23.4-j24\n"
"-35+42.3j\n"
"+24i\n"
"+2.342j\n"
"24.523-i 432,52")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")